PostSharp SDK 6.10 / / Class Reference / Post­Sharp.​Sdk.​Aspect­Weaver Namespace / Aspect­Weaver Class / Aspect­Weaver Methods / Aspect­Weaver.​Add­License­Requirement Method

AspectWeaver.AddLicenseRequirement Method

Note: This API is now obsolete.

Adds a license requirement for the current AspectWeaver.

Namespace:  PostSharp.Sdk.AspectWeaver
Assembly:  PostSharp.Compiler.Engine (in PostSharp.Compiler.Engine.dll) Version: 6.10.14.0 (6.10.14.0)
Syntax
C#
[ObsoleteAttribute("No longer supported", true)]
public void AddLicenseRequirement(
	LicensedPackages requirement
)

Parameters

requirement
Type: LicensedPackages
LicensedPackages required by the current AspectWeaver.
See Also